Извините, ничего не найдено.

Не расстраивайся! Лучше выпей чайку!
Регистрация
Справка
Календарь

Вернуться   www.boolean.name > Программирование игр для мобильных телефонов > MidletPascal

Ответ
 
Опции темы
Старый 04.08.2011, 04:42   #1
reyn90
Нуждающийся
 
Регистрация: 12.10.2009
Сообщений: 66
Написано 0 полезных сообщений
(для 0 пользователей)
Lib_im работает неправельно?

У меня такая проблема. Использую lib_im для получения динамического изображения из сети, т.е. картинка каждый раз меняется, как капча. При загрузке моей программы я использую im.image_from_url('http://chtototam.ru/' + stroka), 0, 0); где строка это текст вводимый пользователем(ссылка выдуманная). Проблема вот в чем: При первой загрузке картинки всё нормально, но вот когда картинка на сервере поменялась, а её имя осталось таким же, загружается старая картинка. Вывожу картинку в Alert. Я предпологаю что:
1.Может нельзя добавлять строку к адресу?
2.Может загруженные телефоном файлы в нем сохраняются и потом если имя совпадает телефон не загружает повторно, а берёт уже готовый.
3.Я плохой программёр.

program tester;
uses im;

var 

textinteger;
okcommand;

exit: 
command;
addstring;

url:string;

begin

ShowForm
;

text:=FormAddTextField('Введите адрес ПОЛНОСТЬЮ!','',25,TF_ANY);

url:='http://chtototam.ru/'+text;
ok:=CreateCommand('ОК',CM_OK,1);
AddCommand(ok);


repeat until GetClickedCommand ok;
mail:=FormGetText(text);


ShowAlert('Итог','Картинка ' add,im.image_from_url(url),ALERT_INFO);

playAlertSound;

repaint;

Delay(15000);

end
(Offline)
 
Ответить с цитированием
Старый 04.08.2011, 08:58   #2
DIMMON4IK
Знающий
 
Аватар для DIMMON4IK
 
Регистрация: 21.07.2009
Адрес: Украина
Сообщений: 219
Написано 44 полезных сообщений
(для 78 пользователей)
Ответ: Lib_im работает неправельно?

попробуй добавить переменную image и в цикле присваивать ей картинку из сети, а в showalert передавать эту переменную вместо библиотеки
ps. зачем repaint когда ты работаешь с формами?
__________________


(Offline)
 
Ответить с цитированием
Старый 06.08.2011, 03:48   #3
reyn90
Нуждающийся
 
Регистрация: 12.10.2009
Сообщений: 66
Написано 0 полезных сообщений
(для 0 пользователей)
Ответ: Lib_im работает неправельно?

Всё исправил ошибку. Оказалось что я не то окончание добавлял для ссылки. )))
(Offline)
 
Ответить с цитированием
Ответ


Опции темы

Ваши права в разделе
Вы не можете создавать темы
Вы не можете отвечать на сообщения
Вы не можете прикреплять файлы
Вы не можете редактировать сообщения

BB коды Вкл.
Смайлы Вкл.
[IMG] код Вкл.
HTML код Выкл.


Часовой пояс GMT +1, время: 19:37.


vBulletin® Version 3.6.5.
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Перевод: zCarot
Style crйe par Allan - vBulletin-Ressources.com